Announcement

Join us on Discord: https://discord.gg/nf43FxS
Acrnstlkr
Member
+11|5172|Iowa, USA
Ok i ping like 40 while searchin for a server, i get in the game and it goes to like 170 wtf? everybody else is 170 to 300+ is this normal?  then it lagggggsss like crazy and i cant even walk without bumpin walls and lookin drunk.
Rod Foxx
Warblgarbl
+78|5159|Perth, Australia
I believe the server browser ping is the most accurate one. The one in-game supposedly uses an old system for determining ping and is very innacurate. Don't ask me for the source though as i have no idea where i read it.
2juk
Member
+12|4353
I know it's Battlefield that's the problem but sometimes if you close out and shut down all the other programs on your PC this will help a little bit.  Make sure your PC is cool all the time too.
TheEternalPessimist
Wibble
+412|5795|Mhz

Mines exactly the same, hopefully it'll get sorted within a year or two
CammRobb
Banned
+1,510|5306|Carnoustie MASSIF

2juk wrote:

I know it's Battlefield that's the problem but sometimes if you close out and shut down all the other programs on your PC this will help a little bit.  Make sure your PC is cool all the time too.
The temperature of your pc does not affect ping
Rofl_My_Waffle
Member
+11|5867
The insane numbers beside your KDR is definitely not ping if that is what you are asking.

I have a G15 Keyboard with the Bad Company 2 app and on the LCD it has a clear line saying "Ping: 50" while the number beside my KDR is somewhere in the hundreds.
Doctor Strangelove
Real Battlefield Veterinarian.
+1,758|5644
In game ping is fucked. And the ping on my server browser doesn't work at all.

But the G19/15 app does show the proper ping so if you have one then go by that.
Trotskygrad
бля
+354|5175|Vortex Ring State

Acrnstlkr wrote:

Ok i ping like 40 while searchin for a server, i get in the game and it goes to like 170 wtf? everybody else is 170 to 300+ is this normal?  then it lagggggsss like crazy and i cant even walk without bumpin walls and lookin drunk.
That's probably graphical lag then. Try turning down your settings.
Cybargs
Moderated
+2,270|5892
I has a bit of lag problems I guess =/ Well the "hit" thing that shows up on crosshair shows up like maybe .5 of sec after bullet hits =/ But I seem to do alright in game lel.
https://cache.www.gametracker.com/server_info/203.46.105.23:21300/b_350_20_692108_381007_FFFFFF_000000.png
Rofl_My_Waffle
Member
+11|5867
There is bullet travel time. So the hit may very well register after you fired your weapon.
Jaekus
I'm the matchstick that you'll never lose
+957|4354|Sydney

Acrnstlkr wrote:

Ok i ping like 40 while searchin for a server, i get in the game and it goes to like 170 wtf? everybody else is 170 to 300+ is this normal?  then it lagggggsss like crazy and i cant even walk without bumpin walls and lookin drunk.
They were updating the hardware for the servers just after you posted this, to fix (supposedly) people's connection issues. Try it again and see if there's any difference.

Some people have reported opening the ports in their firewall/router has helped, try that too.
Adams_BJ
Turns out you were cucked
+2,045|5798|Little Bentcock
pong
Jaekus
I'm the matchstick that you'll never lose
+957|4354|Sydney
I can't even see my in game ping but everything runs fine as far as connection goes.

Had a couple CTD though, anyone else had this?

Board footer

Privacy Policy - © 2022 Jeff Minard