Announcement

Join us on Discord: https://discord.gg/nf43FxS
Discuss.
Finray
Hup! Dos, Tres, Cuatro
+2,613|3438|Catherine Black
So I downloaded WA today, and upon first opening it, I got a crash, "This program is not working properly" blah blah, so I tried a different crack. This kinda worked, I can now get into the game, past the intro, but the colours are all messed up, and when I try to start a game it just CTDs. Tried using compatibility, all the way back to Win95, and running as admin. Installed the 3.6 Beta patch, exhausted my googling skills, and I'm stuck.

Halp?
https://i.imgur.com/qwWEP9F.png
AussieReaper
( ͡° ͜ʖ ͡°)
+5,760|3803|what

Apart from compatibility, did you also try run in 256 colours?
https://i.imgur.com/maVpUMN.png

"coz you a far cry from acclaim nigga ubisoft"
AussieReaper
( ͡° ͜ʖ ͡°)
+5,760|3803|what

The game colours get all messed up

This happens when another application is stealing W:A's palette. W:A logs such occurrences to the file "palette.log" in your W:A folder. If you can, try closing the programs listed there.

Often it's a component of Windows itself that's stealing W:A's palette (usually csrss.exe). If you are using Windows Vista/7, having any Windows Explorer folder open while you play the game has been known to fix it. If this doesn't work, try terminating the explorer.exe process using Task Manager before starting W:A. (Don't worry if the taskbar and desktop icons disappear, that's to be expected.) You can later start it back from Task Manager (which you can open by hitting Ctrl+Alt+Delete or Ctrl+Shift+Esc), by going to File → Run....

You could also try an experimental WormKit module called wkColorFix, which suspends explorer.exe while the game is running (and not minimized).

Another known work-around is to disable the Indexing Service and/or Automatic Updates services (Control Panel → Administrative Tools → Services).
http://worms2d.info/Troubleshooting_FAQ … _messed_up

Try?
https://i.imgur.com/maVpUMN.png

"coz you a far cry from acclaim nigga ubisoft"
Finray
Hup! Dos, Tres, Cuatro
+2,613|3438|Catherine Black

AussieReaper wrote:

Apart from compatibility, did you also try run in 256 colours?
Yep, tried everything on the compatibility tab.
https://i.imgur.com/qwWEP9F.png
FFLink
There is.
+1,380|4341|Devon, England
First result from Googling "Worms armageddon Windows 7"

http://forum.team17.com/showthread.php?t=38232
Finray
Hup! Dos, Tres, Cuatro
+2,613|3438|Catherine Black

FFLink wrote:

First result from Googling "Worms armageddon Windows 7"

http://forum.team17.com/showthread.php?t=38232
Not think I would have tried that?

Reaps, closing csrss.exe gave me a BSoD, I'll try the rest now.

Last edited by Finray (2009-11-21 06:12:52)

https://i.imgur.com/qwWEP9F.png
Finray
Hup! Dos, Tres, Cuatro
+2,613|3438|Catherine Black
So I've sorted the colour problem, but the game still crashes whenever I try to start a game.
https://i.imgur.com/qwWEP9F.png
Finray
Hup! Dos, Tres, Cuatro
+2,613|3438|Catherine Black
specialistx2324 just karmad me saying "That's windows for you noob"...
https://i.imgur.com/qwWEP9F.png
FFLink
There is.
+1,380|4341|Devon, England
Try virtual machine.
Peter
Super Awesome Member
+494|4052|dm_maidenhead
Worms World Party > Worms Armageddon

Board footer

Privacy Policy - © 2017 Jeff Minard