BF3S Forums "Your connection to server has been lost" - FIXED!! A MUST READ!!

mcnitchell
Member
Offline No Xfire No stats No stats No stats No Email No PM No website
+6|2735
I have been pulling my hair out over this damn lost connection to server issue in BF2. Nobody has had a solid solution. I am running an AMD Athlon 64 X2 Dual Core processor. I, well not I but a very knowledgable individual who helped me this morning, discovered that after a short period of time, I was loosing packets and therefore, lost my connection. When we pinged a server, the ping was fine when only sending 32KB packets. Then we sent larger packets. Those larger packets started out good, but then went to NEGATIVE PINGS! This is when I must be loosing my connection to the servers. This is what we found:

When you do a normal ping of a server, such as "ping www.yahoo.com", you only send very small packets of data and have a much less chance of one of those small packets being lost. So, I did this:

ping www.yahoo.com -l 4096 -t

That sent a much larger 4096 KB packet, like a game would, instead of the normal 32KB packet that is sent when "pinging" a server.

For those of you who are having the same problem Im having, check out if youre getting negative pings. The negative ping thing is, as far as I know, only a dual core processor problem though. The fix is simple. Just install the latest AMD processor drivers (see link below). My negative ping immediately went away. I havent played the game yet, as I am too excited to post this in hopes on helping other fix the problem.

YOU MUST READ THE LINKS BELOW!!!

Good luck!

1st = http://www.dslreports.com/forum/remark,15398295

2nd = http://www.amd.com/us-en/Processors/SellAMDProducts/0,,30_177_861_13685,00.html

3rd = http://www.amd.com/us-en/Processors/TechnicalResources/0,,30_182_871_13118,00.html
mcnitchell
Member
Offline No Xfire No stats No stats No stats No Email No PM No website
+6|2735
Also, for those of you that dont know how to ping a server, check out this link...

http://www.more.net/technical/pingtrace.html
Homie22
Member
Offline No Xfire No stats No stats No stats No Email No PM No website
+34|3052|Orange County, California
MOD PLZ sticky this xd
mcnitchell
Member
Offline No Xfire No stats No stats No stats No Email No PM No website
+6|2735
Follow up:

Just played for 2 hours straight with no disconnects! Thats a first!
[AH1z]PJ
Member
Offline No stats No stats No stats No Email No PM No website
+75|2797
I dont see AMD athlon 64 drivers for windows on that page
some_random_panda
Flamesuit essential
Offline No stats No stats No stats No Email No PM No website
+454|2831

BF2S Honors:
BF2S Game Admin

I rarely have disconnects, and It's common for me to play for long periods of time with no problems.  Then again, I have Intel C2D.
Commie Killer
Member
Offline No Xfire No stats No stats No stats No Email No PM No website
+192|2827
I have a 2.5 ghz P4 and I havent had a crash in my last 100 hours maybe 150.
[AH1z]PJ
Member
Offline No stats No stats No stats No Email No PM No website
+75|2797
I have a problem where my game freezes and goes like "1-2, 1-2, 1-2....." for like 20 seconds then I get a "theres a problem with your connection" error and get disconnected
Ridir
Semper Fi!
Offline No stats No stats No Email No PM No website
+48|3204
if only this would work for me, I have roommates that decided that they are going to always be downloading stuff so I can never get a stable connection.  I haven't been able to play for months.
bobroonie.bda
Member